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Birthdays and Such… User’s Guide

Chapter 1 : Introduction
Birthdays and Such… is an application meant to be launched on daily startup, to remind you of 
the important birthdays and anniversaries in your life. It works for me, which has made me the 
envy of all my friends and relatives. By setting reminders 10 or so days ahead, I find I’m as on 
the ball as the best of the rest of my friends and relatives in remembering to buy cards and 
presents (and to actually send them)—and way ahead of the date-impaired. 

Now admittedly you’re going to have to type in a list of all the important dates you want to 
remember. But this is a one-time task. From then on, you’re home free (ok, ok, you still have to 
add and remove friends and relatives as they’re born and die...). But that certainly beats my 
previous annual efforts to write every date onto the family calendar or into my day-timer. And it 
results in a list that, printed out from your word processing program, makes it easy to buy your 
whole year’s cards in one shopping trip!

So the steps are simple (with details below): You type your list of important dates into a text file 
you call “Reminders” (yes, the name is required). You set Birthdays and Such… to run every 
time you start your Macintosh. And you locate the Reminders file where Birthdays and Such… 
can find it.

Then every time you turn on your Macintosh, it starts up Birthdays and Such… The program 
looks up the current date, then scans the Reminders file for upcoming events. And voilá, in the 
topmost window on your screen, it displays just those—the ones you need to do something 
about. 

It’s at this point—before I choose Quit from the File menu in Birthdays and Such…—that I write
myself a little note (and put it in my pocket) to buy a card, or I pull out the card I bought earlier.

And if you leave your Macintosh running for days at a time, Birthdays and Such… will update to
the next day’s reminders every night on the stroke of midnight.
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The program name “Birthdays and Such…” 

Birthdays and Such… ends with an ellipsis character because there are so many dates beyond 
birthdays and such to remember…  (I have added reminders for such purposes as filing for 
reimbursement of certain recurring expenses, changing my 401K contributions, paying for my 
Grand Canyon reservations, and visiting my dentist, for example.)

Version 1.0 

Version 1.0 has been extensively tested, and it is my belief that there are no bugs of any kind (I 
know, I know, famous last words and all…). Well, how about this: I’ve been using Birthdays and 
Such… for almost two years now on Macs ranging from SEs to Quadras, Performas to 
PowerMacs—without a glitch.

What you need to run Birthdays and Such… 

Birthdays and Such… runs on almost every Macintosh computer that’s been made. To use 
Birthdays and Such…, make sure you have the following minimum system:

• a Macintosh computer made in 1986 or later (that is, not  a Mac 128 or Mac 512)
• system software version 6.0 or later (actually, System 6.0.4 or later may be required)

If you’re not sure which system you have, choose the About The Finder or About This Macintosh
command from the Apple menu (these commands only appear when you’re in the Finder).

Distribution 

Birthdays and Such… is shareware. (No, not for my relatives and friends. Don’t be silly. I sent it 
to each of you as a gift. But if you’re not already one of my friends, relatives and acquaintances, 
Birthdays and Such… is  shareware.) 

Birthdays and Such… is NOT  a free or public domain program.

As with most shareware, please try it for yourself for a day, a week, a month. Unlike most 
shareware,  however, Birthdays and Such… is What’sItWorthWare—that is, I believe in user-
determined pricing. You decide what Birthdays and Such… is worth. Then send me a money 
order or a check (see Chapter 7). (What’s it worth to save your marriage? What’s it worth to 
maintain your relationship with your parents? OK, maybe Birthdays and Such… won’t do that all
by itself, but...  :-)

Please keep Birthdays and Such…, the sample Reminders file, the manual, and any addendum or
readme files bundled together, if you pass it on to someone else.
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Chapter 2 : Installing Birthdays and Such…
To install Birthdays and Such…:
1) Turn on your Macintosh.
2) Insert the floppy disk labeled Birthdays and Such in the floppy disk drive of your Macintosh.
3) Copy the icon labeled Birthdays and Such… to an appropriate folder on your hard disk (I 

keep mine in a folder labeled Utilities). 
4) Copy the icon labeled Reminders into the same window or folder on your hard disk as the 

one you just copied Birthdays and Such…  to.
5) Eject the Birthdays and Such disk.

Installation is now complete. 

Auto-Startup Installation:
Most people will want Birthdays and Such… to run every time they turn on their 
Macintosh computer, so they’ll be reminded of upcoming birthdays and anniversaries at 
least that often. If you would like the program  to run every time you turn on your 
Macintosh, continue with the following instructions. 
1) Select the icon labeled Birthdays and Such… (click once on the icon). 

Remaining installation instructions for System 6 users:
If you use System 7, skip to the section titled “Remaining installation instructions for System 7 
users.” This section is for System 6 users:
2) Choose the Set Startup command from the Special menu.
3) Click the radio button labeled Birthdays and Such…  (If Birthdays and Such… is not one of 

the options, click the Cancel button and go back two steps in these instructions to step 1.)
4) Click the OK button.

If you’re a System 6 user, auto-startup installation is now complete. Now every time you turn on 
your Macintosh computer, Birthdays and Such… will start up, look through the Reminders file, 
and remind you of the upcoming events in your life.

Remaining installation instructions for System 7 users:
2) Choose the Make Alias command from the File menu.
3) Drag the new file labeled Birthdays and Such… alias into the Startup Items folder, which is 

located inside the System Folder.

Auto-startup installation is now complete. Now every time you turn on your Macintosh computer,
Birthdays and Such… will start up, look through the Reminders file, and remind you of the 
upcoming events in your life.

Öptional Step: To force the Birthdays and Such… reminders window to appear as the top 
window (to be “in your face”, so to speak), rename the application and the alias to begin with a 
‘•’ (type the key combination, option-8). (This works because the bullet sorts alphabetically after 
all the letters and numbers, and after many special characters.) (Note, however, that Startup 
Items that are desk accessories or documents will foil this plan: they will open on top anyway, 
since DAs and documents open after applications.)
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Now double-click Birthdays and Such… The four changes of season are in the sample 
Reminders file, each with a long enough reminder period to guarantee there’s a reminder 
every single day—so you can get a flavor of Birthdays and Such… right away.
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Chapter 3 : Setting Up the Reminders File
The file you create of all your important dates, which must be named “Reminders”, is the source 
of information for Birthdays and Such… 

Each Reminder in the Reminders file can be uniquely assigned a number of days before the date 
that you want to be reminded about the event.

Acceptable locations for the Reminders file  

The Reminders file (which must have the name “Reminders”) must be located in one of two 
places:

• in the same folder as Birthdays and Such… , or
• in the System Folder

Birthdays and Such… reads in the file, looks through all the reminders in it, and evaluates them 
to find those which are, today, applicable (those for which today's date is within the reminder 
period). Then it displays those reminders in a list on the screen.

How to edit the Reminders file

Reminders is a text file that can be created by any word processor that can save a file as ‘text’. 

The simplest way to edit Reminders is to use TeachText or SimpleText, one of which is located 
on almost every Macintosh. (Instructions for using other word processors to edit Reminders can 
be found at the end of this chapter.)

The sample Reminders file was created in TeachText (on recent Macintoshes called 
SimpleText). To edit Reminders, simply double-click its icon. If you have TeachText or 
SimpleText, it will launch, opening the Reminders file. When you’ve made your changes, choose
Save from the File menu. Then close the document (choose Close from the File menu). Double-
click Birthdays and Such… to see the results (if any would be displayed today) of your changes.
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The format for each Reminder 

The format in the text file named “Reminders” is a series of records, each several lines long, 
each line a single field. You have to press the return key when you add new lines to the 
document, and not just let the line wrap (Nerd translation: each line must be terminated by a 
carriage return character).

The fields are in the following order:
date date of reminder
warning-period n  days prior to date  to begin reminding (1 or 2 digits; 0-99 days)
Reminder the text to display as a reminder
- record separator (a dash as the first character on the line)

So reminders consist of just the first three fields, followed by the record separator line (a single dash as the 
first character on the line).

Here’s an example file with three reminders:

January 14
2
David’s birthday (1955).
-
January 23
10
Grandma’s birthday .
- 
July 19
10
Author Ron Lichty’s birthday, P.O. Box 27262, SF, CA 94127.
- 

So in the example, you would be reminded of David’s birthday from January 12-14, Grandma’s 
birthday from January 13-23, and Ron’s birthday from July 9-19.

While the example shows the birthdays in date order, that’s not necessary. But I personally find it
easier to look through the Reminders file and keep track of everyone by doing it that way. 
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The   date    Field: International Date Formats   

Dates should be written in a form that is native to the language and region of the system software
you are using. (Nerd note: a part of system software called the Script Manager is used to read the
dates from the file; the date routines weren’t added to the Script Manager until version 2.0, 
which was released with System 6, which is why System 6 or later is required.)

The most common valid English date formats, for example, would be:
September 20
Sept 20
Sept. 20
9/20

European French systems, on the other hand, would probably expect (try it and let me know):
20 septembre
20 sept
20 sept.
20.9

I haven’t tested how well this works in other regions, but that is the point of the routines, so I 
would expect them to work fairly intuitive to your language and region.

The   warning-period    Field   

This is the number of days prior to the reminder’s date that you’d like the program to remind you
about it. It’s a one- or two-digit number from 0 to 99. 

The number ‘0’ indicates that you want to see the reminder only on date itself—no prior days. 
The number ‘1’ means you want to be warned the day before in addition to on the date itself. 
And so on. If the reminder’s date is October 30, and the warning period is 2 days, you’ll be 
reminded from October 28th through October 30th.

I often set warning periods of 10 days for distant relatives for whom I need to buy a card and 
send it. But I may set only a 2-day warning for local friends, to remind me I will want to call 
them on their actual birthdays.

The   Reminders    Field   

This one line of text is the line that Birthdays and Such… will show you when the reminder is 
valid—from the beginning of the warning period through the date of the reminder itself. It’s 
limited to a single line of perhaps 70 or so characters. If you get too many, they’ll just disappear 
off the right edge of the window.
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Using other word processing programs to edit the Reminders file  

Here are instructions for using various common word processing programs to edit a text file. 
Note that the instructions may change as word processors are updated with new versions.

To use Microsoft Word, choose Open from the File menu, make sure the “List Files of Type” 
popup is set either to Readable Files or to Text Files, navigate to the Reminders file, select 
Reminders, and Open it. When you’ve made your changes, choose Save from the File menu; 
provided you haven’t tried (even inadvertently) to use bold, underlining, another font, or other 
formatting commands, Microsoft Word will maintain the TEXT file type.

If, instead, you were to start a new Reminders file in Microsoft Word, the first time you save 
Reminders, select Text Only in the popup menu labeled “Save File as Type”; if you forget (or if 
Word forgets, which it occasionally does), choose Save As... from the File menu, type in 
Reminders again as the filename, and select Text Only in the popup menu labeled “Save File as 
Type” (you’ll be prompted to confirm that it’s ok to replace the previous Reminders file). 
(Special power user note: As a power Word user, I have a custom Work menu; since I tend to add
birthdays to Reminders all the time, as I meet people, I added Reminders to my Work menu; that 
way I don’t have to think about where the file is actually located—I just choose Reminders from 
Word’s Work menu to open it; then I edit it, save it, and close it.)  

To use MacWrite 5.01, choose Open from the File menu, navigate to the Reminders file, select 
Reminders, and Open it (select the “Paragraphs” button to the Carriage Return prompt; and 
“OK” to the Document Being Converted prompt). When you’ve made your changes, choose 
Save from the File menu, click the “Text Only” radio button, type in Reminders as the file’s 
name, and click Save. (You’ll additionally have to click Replace to “Replace existing 
‘Reminders’?”; and “Paragraphs” to the Carriage Return prompt.) Then close the document in 
MacWrite 5.01 (you’ll additionally have to click No to “Save changes before closing?”).

To use MacWrite II, choose Open from the File menu, make sure the “Show” popup is set either
to All Available or to Text, navigate to the Reminders file, select Reminders, and Open it. When 
you’ve made your changes, choose Save As from the File menu, set the “Save As” popup to Text,
type in Reminders as the file’s name (or simply delete “ (Converted)” from after “Reminders”—
be sure to remove the space character between “Reminders” and “(Converted)”), and click Save. 
(You’ll additionally have to click Replace to “Replace existing ‘Reminders’?”) Then close the 
document in MacWrite II (you’ll additionally have to click No to “Save changes to ‘Reminders 
(Converted)’ before closing?”).

To use MacWrite Pro, choose Open from the File menu, make sure the “Show” popup is set 
either to All Available or to Text, navigate to the Reminders file, select Reminders, and Open it. 
When you’ve made your changes, choose Save from the File menu, set the “Save As” popup to 
Text, type in Reminders as the file’s name (or simply delete “ (Converted)” from after 
“Reminders”—be sure to remove the space character between “Reminders” and “(Converted)”), 
and click Save. (You’ll additionally have to click Replace to “Replace existing ‘Reminders’?”) 
Then close the document in MacWrite Pro (you’ll additionally have to click No to “Save changes
to ‘Reminders (Converted)’ before closing?”).
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To use ClarisWorks, choose Open from the File menu, set the “Document Type” popup to Word
Processing (make sure the “File Type” popup is set to All Available or to Plain Text), navigate to 
the Reminders file, select Reminders, and Open it. When you’ve made your changes, choose 
Save from the File menu, set the “Save As” popup to Plain Text, type in Reminders as the file’s 
name (or simply delete “ - Converted” from after “Reminders”—be sure to remove the space 
character between “Reminders” and 
“- Converted”), and click Save. (You’ll additionally have to click Replace to “Replace existing 
‘Reminders’?”) Then close the document in ClarisWorks (you’ll have to click No to “Save 
changes to ‘Reminders - Converted’ before closing?”).

To use Microsoft Works, choose Open from the File menu, click the Word Processor icon, click 
the Import File check box so the Reminder icon will be visible, navigate to the Reminders file, 
select Reminders, and Open it. When you’ve made your changes, choose Save As from the File 
menu, click the Export File checkbox, type in Reminders as the file’s name, and click Save. 
(You’ll additionally have to click Yes to “Replace existing Reminders?”) Then close the 
document in Microsoft Works.
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Chapter 4 : Birthdays and Such… options
Birthdays and Such… is so simple that it has only one option. Nonetheless, balloon help (System
7 or later) is available for Birthdays and Such… Choose Show Balloons under the Help menu to 
browse the capabilities of Birthdays and Such…

The AutoQuit option

Some users who launch Birthdays and Such… every day would prefer not have to look at an 
empty list, then manually quit the program, when there are no reminders that day. For these 
users, there is an AutoQuit option.

When the list of reminders is displayed, you will see, in addition to the three standard menus (the
Apple, File and Edit menus), a Reminders menu. Pull down the Reminders menu and you’ll see a
single option: 

AutoQuit If No Reminders

If you choose this option, the next time you pull down the menu there will be a checkmark in 
front of it. And the next time you launch Birthdays and Such…, it will automatically 
immediately quit if there are no reminders to display.

You will want to choose this option only if you launch Birthdays and Such… daily (whether by 
double-clicking it, or by making it part of your Startup Items). If, on the other hand, you rely on 
the Birthdays and Such… automatic update feature (re-evaluating the Reminders file at midnight
every night), then this option will stymie your intentions: Birthdays and Such… will hit the first 
hole in your reminders, quit, and never reappear.

If today is a date with no reminders, and the AutoQuit option is turned on, then Reminders will 
launch and automatically quit. Unfortunately, the only way to disable the feature is to have 
Birthdays and Such… running, but it won’t run until there’s a reminder to display. Catch 22. You 
can solve this in one of two ways:
• Change the date in the General Controls or Date & Time control panel to a date for which there 
is a reminder (be sure to change the date back after unchecking the AutoQuit command).
• Add a reminder to the Reminders file that is applicable today.
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Chapter 5 : Errors
The Current Date is wrong 

If the date that Birthdays and Such… displays is incorrect, then your Macintosh’s internal clock 
is off. You can fix it using a Control Panel. Under System 6, the date and time are set in the 
General control panel. Under System 7, the date and time are set in either the General Controls 
control panel or the Date & Time control panel. In either system, find the Control Panels by 
pulling down the Apple menu.

Birthdays and Such… launches, but quits right away! 

If today is a date with no reminders, and the AutoQuit option is turned on (see the previous 
chapter), then Reminders will launch and automatically quit. Unfortunately, the only way to 
disable the feature is to have Birthdays and Such… running, but it won’t run until there’s a 
reminder to display, and obviously there’s not one today! Catch 22. 

You can solve this in one of two ways:
• Change the date in the General Controls or Date & Time control panel to a date for which there 
is a reminder (be sure to change the date back after unchecking the AutoQuit command under the
Reminders menu).
• Add a reminder to the Reminders file that is applicable today.

Error messages 

At some point, you may encounter an error while running Birthdays and Such…  Here are some 
error dialogs with the messages they present, and what to do about them.

The Reminders file (which must have the name “Reminders”) must be located in one of two places:
• in the same folder as Birthdays and Such… , or
• in the System Folder

If you get this error, make sure “Reminders” is correctly named (even a space character before or after 
the name would prevent Birthdays and Such… from recognizing it as its Reminders file), and then make
sure it’s located in one of the acceptable locations.
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The Reminders file must be saved as a text file, not in the usual format used by your word processor. If 
you get this message, you’ll have to open the document in your word processor again, then save it as a 
text file using the method your word processor provides to save documents as text files. See Chapter 3: 
Setting Up the Reminders File  for an explanation of how to save documents as text files from many 
common word processing programs.

When  Birthdays and Such…  reads in the Reminders file, it checks the date at the beginning of each 
reminder. If that date is invalid (such as Fev. 12 or 3/42),  Birthdays and Such…  will present you with 
this message. You’ll want to edit and re-save the file (remember to save it as a text file) or  Birthdays 
and Such…  will never remind you of these invalid-date reminders.

If you have an incredibly large number of reminders in your Reminders file, it is possible to overwhelm 
the memory partition reserved for  Birthdays and Such…   Should that happen, and you’re presented 
with this message, select the icon for  Birthdays and Such…  in the Finder, and choose the Get Info 
command from the File menu. Then type a slightly larger value than is already displayed into the 
Memory Size box(es).
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Finally, it is possible that some error could occur that was not anticipated. If that occurs, and you get this
message, fill out a copy of the error report form at the end of this manual and mail it to the author.
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Chapter 6 : About the Author
Ron Lichty, 45 years old, lives in San Francisco, and is director of development for Fujitsu Cultural 
Technologies, maker of WorldsAway, a third-generation animated virtual world (on CompuServe, Go 
“Away”; or visit our web page at http://WWW.WorldsAway.com/). He previously was director of 
engineering for screen savers at Berkeley Systems. And before that, he spent six years at Apple 
Computer. He worked at Apple as a Finder engineer, an Installer engineer, and a manager of 
development tools product marketing, and then from 1991 to 1994, he managed Macintosh Finder 
Engineering. 

Before joining Apple, Ron worked for Softwest, a Sunnyvale software consulting company. There, he 
wrote compiler code generators, co-authored a spell-checking program for the Apple II and Macintosh 
computers, and was awarded several patents for work on card-access electronic hotel locking systems 
and on smart-card money-access terminal systems. Also at Softwest, he was contracted by Apple 
Computer to co-design and program the Apple IIGS Sales Demo Program; featuring digitized music and
graphics, animation, dissolves, and speech, it was translated into five languages and used to debut the 
computer in 1986. In his spare time, Ron has co-authored two assembly language programming books—
one a reference, the other a tutorial.

Prior to his 15 years in the computer industry, Ron worked for 10 years as a writer, editor, and freelance 
graphic designer in nontechnical fields. Brochures he designed launched a wide variety of companies, 
services and products. His freelance articles from New York and California appeared widely in regional 
and national magazines. He started a small magazine in the Chicago area. He was a daily newspaper 
reporter/photographer in Wyoming. And he authored two successful nonfiction books, one a compleat 
guide to newspaper and magazine publishing, the other an inspirational/how-to guide called 132 Ways to
Earn a Living without Working (for Someone Else).

After he became one of the first authors to buy a computer for word processing, in 1980, he teamed up 
with another early adopter of computer technology to teach a course that, during the early 1980s, helped 
hundreds of Bay Area writers and authors select computers and word processing software. Ron also 
shared with other authors his experiences and research into publicizing and promoting books through 
classes at San Francisco State and San Jose State Universities. Ron has owned and run several mail 
order companies that sold books by mail. 

Ron has a grandmother, two parents, two children, a wife, four brothers and sisters, lots of friends, and 
scads of nieces and nephews whose birthdays and anniversaries he dutifully remembers with the help of 
Birthdays and Such… 

Ron welcomes comments, error reports and suggestions at:
Ron Lichty
P.O. Box 27262
San Francisco, CA  94127

or electronically at:
America OnLine: RonLichty
Internet: RonLichty@aol.com
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Chapter 7 : Birthdays and Such… is shareware 
Birthdays and Such… is shareware. (No, there’s no shareware fee for my relatives and friends. 
Don’t be silly. I sent it to each of you as a gift. But if you’re not already one of my friends, 
relatives and acquaintances, Birthdays and Such… is shareware.) Birthdays and Such… is NOT 
a free or public domain program.

What is shareware?

1) If you keep using it, you must pay for it

As with most shareware, please try it for yourself for a day, a week, a month. Unlike most 
shareware,  however, Birthdays and Such… is What’sItWorthWare—that is, I believe in user-
determined pricing. You decide what Birthdays and Such… is worth. Then send a money order 
or check (or even cash) to:

Ron Lichty
P.O. Box 27262
San Francisco, CA 94127

(What’s it worth to save your marriage? What’s it worth to maintain a relationship with your 
parents? OK, maybe Birthdays and Such… won’t do that all by itself, but...  :-)

If you don’t like it, drag it to the Trash and you’ll owe me nothing. But if you do continue to use 
it, you do owe me a fee—it’s just that with What’sItWorthWare, you not only get to try the 
software before you pay for it, but you also get to decide its value. I don’t care whether the 
amount you send is a dollar or a hundred dollars, provided 1) that you send me something, and 2)
that what you send me represents what you believe it’s worth.

2) If you like it, share it with your friends and relatives

The second element of shareware is that it gets distributed by people who like it and use it—
sharing it with their friends. I urge you to share it. Your friends urge you to share it (OK, they 
would if they knew you had it, and how useful it is to you). Your friends deserve to know about 
the programs that keep your life together. Give them a disk with Birthdays and Such…, PopChar,
Applicon, TypeItForMe, SCSIProbe, GunShy, BinHex4.0, Alias Meister, DOSWasher, and the 
other freeware and shareware programs you couldn’t do without.

When you do share Birthdays and Such…, please keep it together with the sample Reminders 
file (you may want to add your birthday, so your friends are reminded of the most important  day 
of the year! :-), the manual, and any addendum or readme files, and pass them all on. You must  
keep the manual with the program if you pass it on—that’s the second shareware requirement. 
(What was the first again? Oh, right, paying the author...)

The third restriction is that you cannot modify the program or manual in any way, sell it, or 
include it on a disk which is sold without my prior written consent (this also applies to freeware 
and shareware distribution outfits such as, but not limited to, Educorp et al.). With the exception 
that clubs and user groups may charge a nominal fee (not to exceed $10) for expenses while 
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distributing Birthdays and Such…

Thank you in advance for keeping the What’sItWorthWare spirit alive!
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Appendix : Legalities
Legalities 

Any names and/or information that are registered trademarks of any company, corporation or 
group are hereby respected and acknowledged.

Birthdays and Such… is Copyright © 1993-1996 by Ron Lichty. All rights reserved.

Warranty 

To the best of my knowledge (derived in considerable part from years of use and testing), 
Birthdays and Such… is “harmless”. Nonetheless, Birthdays and Such… is offered “as is” and is 
not covered by any warranty of any kind, so use it at your own risk. If you do find a bug, I’d like 
to hear about it—I may not be able to fix it, but I’d at least like to know about it.
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Programmer Talk 

This program was written in MPW C  v. 3.2, and debugged using Apple Computer’s Voodoo 
Monkey, an offshoot of SourceBug. I found Symantec’s Think Reference to be a very useful on-
line substitute for Inside Mac. I found a set of freeware tools called Tags for MPW to be terrific. 
To get my icons to appear (without rebuilding my desktop dozens of times), I used Tim Swihart’s
freeware tool BNDL Banger. 

While developing this simple application, I found no sample code for making sure that, when it’s
opened, a window’s location will be on the screen (a problem you might have seen with 
Birthdays and Such… only if you changed monitors—but Excel users who are given 
spreadsheets with no visible window because they were created on their boss’ second monitor 
will know what I mean). As a good programming citizen (and a curious programmer), I 
determined that no user of mine would lose the Birthdays and Such… window into “outer 
space.” To do that, I discovered I had to calculate the window’s title bar height. And I found 
doing that to be a whole lot harder to do correctly than I’d expected (and for more than just me: I
also uncovered a related bug in Inside Mac). All of that led me to update two of Apple 
Computer’s Toolbox Tech Notes (TB 14 and TB 575), and to write sample code for the above 
operations. I’d like to thank Dean Yu and Nick Kledzik for reviewing (and giving me lots of 
corrections to) both my writing and the sample code.
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Error Report

If you encounter the “Unexpected error” dialog—or any behavior of Birthdays and Such…  that you 
didn’t expect, please fill in a copy of this report, and mail it to:

Ron Lichty
P.O. Box 27262
San Francisco, CA 94127
America OnLine: RonLichty
Internet: RonLichty@aol.com

Your name and address:

Your phone number, with area code:

Which Macintosh model you are using:

Which System Software version you are using (in the Finder, choose “About…” from the Apple menu):

Additional comments on your hardware and/or software configuration:

In what folder is Birthdays and Such…  located?

In what folder is Reminders  located?

(  )  You were presented with the “Unexpected error” dialog.

(  )  Birthdays and Such…  didn’t work the way you think it should.

(  )  Other:

What happened:
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Describe the sequence of events that led up to the dialog or aberrant behavior:
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